#4926926
I used two buck converters in my setup powered by a single 11.1v lipo. One powers the arduino and lights and the other the fx board and audio amp. The delay could still be caused by weak connections. Maybe try moving the component to a different part of the breadboard. Some of the cheap breadboards I've found have issues with some connections. The most likely place where the loop would pause would be in the audio board calls to read the state so make sure the ACT pin connection is good. The other place I've seen pauses is in the actual play function which I believe is caused by blocking serial communication. Double check those wires as well.
#4927168
Another day....another problem. lol....at least I'm having fun right? Ok, so I got everything wired up and working on the bench so I figured it's time to to play with the relay and setting up a smoke vent. This doesn't seem that hard right? Well for whatever reason I can't get this to work to save my life. The relay is working...the green and red leds come on when powered on and I hear a distinct click when the switch is fired to turn it on and off....BUT.....it doesn't seem to have any voltage running out of the DC+ and DC- leads? For testing I'm inserting a common 5V LED bulb (as well as a multi-meter) and it's just not out putting any power. I've tried three different relays and all perform the same. So what am I doing wrong? Below is an illustration of my wiring. Any help is appreciated!

Image
#4927178
Think of a relay as a remote controlled toggle switch. A relay is made of two separate circuits. the control side (on the left in your picture) is the low amp circuit that is getting the input signal from your Arduino. You have that wired correctly, don't change that side . BUT, the other half of the relay is nothing more than a switch that is turned on and off by the control side. it is not electrically connected to the control circuit and it does not provide power to the circuit it controls. When you are wiring it in to the circuit you want it to activate, you have to wire it the same as a simple switch. you will put it in series on either leg of that circuit, but that circuit needs its own power source.
Hope this helps.
#4929336
i'am curious to know if someone can tell me how i can including some other "mode" in this code.

if i dont want use "toggle switch" for theme song but instead use this toggle for switch to different mode.

Example : normal mode, slime mode and stasis mode.

For now i have 3 separate .ino files representing the 3 modes.

how i can crush all this 3 mode togheter and be able to switching between each mode with a toggle switch? Iam not super good for create from scratch for coding but iam good to remix and test/error shot

some example code ? that's could help me so much
thanks
#4929576
Ok....I got almost everything wired up (except the Ecig and vent lights) and it appears to be working EXCEPT when I flip off the activate/safety switch. I hear the "clicktrack" and wand lights shut off but the bar graph just freezes in place. I had it working on the bench (so the bar graph lights shut off when the activate was turned off). So my question is obviously the switch it working. Any idea where I might want to look for a bad solder joint or loose connection? Everything else seems to work (theme switch, on/off. trigger) perfectly expect that sequence....Any ideas?!
#4929602
That is strange that everything worked on the bench but not now. In the code the shutdown_leds(); function is what clears the bar graph. in the main loop that is called in the last else statement that does all of the shutdown of the pack.
} else { // if we are powering down
if ( poweredDown == false ) {
if ( shuttingDown == false ) {
playAudio(shutdownTrack, playing); // play the pack shutdown track
shuttingDown = true;
}
cyclotronRunningFadeOut = 255;
powerSequenceShutdown(currentMillis);
} else {
if (startup == true) { // if started reset the variables
clearPowerStrip(); // clear all led's
shutdown_leds();
startup = false;
safety = false;
fire = false;
}
}
}
EDIT: ok what is the point of the code block if it won't keep the code formatting? Quote seems to work a little better...

if you look at what that code is doing it will loop during the powercell shutdown faze and then once the shutdown is complete it will clear the powerstrip and bargraph. My guess is that for some reason the final clearing is not being called. Did you change the number of led's in the powercell by any chance?
#4929648
Really? That is incredibly strange. The code is there to clear the bargraph but since my pack does not have it I can't test it and verify it is still working. I don't see anything in the code that would indicate a problem since if the powercell is reset the bargraph should be as well. I'll take another look tomorrow to see if I see anything
NotSabbat liked this
#4929710
is it possible that the powercell offset index is 0 in your configurations? Around line 891 in the ecig code you can see this if statement

if ( powerShutdownSeqNum >= powercellIndexOffset) {

It's possible that is not being satisfied for some reason and therefor the poweredDown = true; and reset of the powercell/bar graph is not happening. Powercell may not be noticable since it's already shutting lights down till the end.

I'm not sure how that is not being satisfied but without being able to debug it that is the only place I see where that could be missed. Once the poweredDown is set to true it should clear the bar graph.

it does look like I may have written the power down sequence after I stopped working on the bar graph code so I may never have tested the bargraph shutdown after the animation was complete.
#4929949
Random question - Are there any other pins on the Arduino Nano that aren't being used? The reason I ask is I'm having a hell of a time getting the Relay to Work? I'm honestly not sure if it's the Pin or not, but the relay always stays on? I've tried changing the HIGH/LOW statements in the code, I've powered the relay from both the arduino as well as separate 5v power and nothing seems to work....I'm just wondering if something might be wrong with D13? Any ideas?
#4929957
if it was working on the bench that usually indicates some sort of issue with the final soldering of the components. Just to be safe when I have gremlins like this I always hit each pin with a soldering iron to make sure good contact is being made. Could be a cold solder joint or something. It's highly unlikely just one pin on the arduino would fail. Usually when I fry arduinos it just won't boot at all.
#4929969
Quick update.....I bypassed the buck converter and ran the arduino nano directly off the battery and then 5V power lead directly to the relay.....turned it on and the relay works flawlessly? No idea why it didn't like it's own power supply directly out of the buck from the battery? (and yes I checked the voltage from the buck...it was dialed in at 5.05 volts.)
  • 1
  • 15
  • 16
  • 17
  • 18
  • 19
Wands

So im looking to get a new full sized wand. Im wo[…]

I may have missed it. Was that a BOK or Throwing C[…]

I am pretty curious where they plan on using the[…]

GB hero pack ( GBfans Shell)

I haven't had a chance to work on the Nfilter yet […]